problem with tymeleaf dependency javassist:3.11.0.GA with java8

classic Classic list List threaded Threaded
3 messages Options
Reply | Threaded
Open this post in threaded view
|

problem with tymeleaf dependency javassist:3.11.0.GA with java8

Peter Ferenczy
Hi,

i ran into a problem using the latest tymeleaf with java8: https://bugzilla.redhat.com/show_bug.cgi?id=1089975

the dependency package has some problem with java8: javassist:3.11.0.GA

please update to javassist:3.18.1-GA if possible, probably some of the thymleaf dependencies pull in the outdated version of javassist...

if you want to maintain the java6+ compatibility, make a java8 compatible package.. :)

thank you
Peter Ferenczy
Reply | Threaded
Open this post in threaded view
|

Re: problem with tymeleaf dependency javassist:3.11.0.GA with java8

danielfernandez
Administrator
Thanks. The OGNL dependency in the Thymeleaf 3.0 branch has been updated to OGNL 3.1.4, which uses javassist 3.20.0.GA.
Reply | Threaded
Open this post in threaded view
|

Re: problem with tymeleaf dependency javassist:3.11.0.GA with java8

Peter Ferenczy
Thank you!